Honda Grom Forums banner
1 - 5 of 5 Posts

·
Premium Member
Joined
·
941 Posts
Discussion Starter · #1 ·
.

As most of you know, there are many many exhaust available for the Grom.

But, for our Grom Project Bike, we felt Yoshimura was the way to go.

We have had a long standing relationship with Yoshimura for over 15 years.
They make great exhausts.

And for the Grom, this Yoshimura exhaust not only looks amazing, sounds amazing, but shed nearly 8lbs of weight off the bike.

It's also fit absolutely, perfect.

Super easy to install.

And after we swapped out the exhaust, and went for a test ride, the improvement was very impressive.
Much more low end grunt and more power through the entire RPM range.

We had NOT installed a Fuel Controller yet... at that point.
It was all the Exhaust.


STOCK EXHAUST_____ 12 lbs 11 oz
YOSHIMURA Exhaust__ 4 lbs 14 oz
---------------
WEIGHT SAVINGS: nearly 8 lbs


So we know many have done this video.
But, we tried to add a little more step by step details and information when we did ours.

Plus it's more enjoyable to watch our Resident Grom Girl. :)


Hope you enjoy.

.







.


>> [ame="http://www.youtube.com/watch?v=j7owWuw-cLY"]Honda Grom Yoshimura RS9 Full Exhaust - Installation - YouTube[/ame] <<




.
 

·
Registered
Joined
·
134 Posts
Waiting to hear if your grom goes into ecu retard mode after exhaust swap

Like for instance being able to ride 60+ easily up to 65 and then 15mins later same stretch of road grom ecu decides to limit me to 58mph pinned on end. I have a full yoshi and knn right on throttle body. Ppl still have this issue when running the bazzaz units from what ive seeen posted on either this or other forum
 

·
Premium Member
Joined
·
941 Posts
Discussion Starter · #3 ·
Waiting to hear if your grom goes into ecu retard mode after exhaust swap

Like for instance being able to ride 60+ easily up to 65 and then 15mins later same stretch of road grom ecu decides to limit me to 58mph pinned on end. I have a full yoshi and knn right on throttle body. Ppl still have this issue when running the bazzaz units from what ive seeen posted on either this or other forum
.

Haven't had that issue yet.

But, only put about 15 miles on it, then started pouring rain.

Will try to get more riding time this weekend.


Also doing the Bazzaz today as well.

Then we will get the Z-AFM welded up to make a custom map.



.
 

·
Registered
Joined
·
134 Posts
Search around a few ppl having issues with bazzaz w auto mapper.

Something about open and clsed loops and bazzaz is communicating with the wrong ones, guys autotuner was always continusoly running super rich, he found his adjustment maxxed out and grom ecu was still leaning the mixture more then he can compensate for
 

·
Premium Member
Joined
·
941 Posts
Discussion Starter · #5 ·
.
We did find the one guy with this issue.
Thinking it's a firmware update... because we have sold over 34 of these ZFi units, and no issues reported thus far.



.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top